Error when I run SNDK demo in Linux  

  RSS

MauroD
(@maurod)
Active Member
Joined: 8 months ago
Posts: 11
23/11/2018 10:11 pm  

Hello, I tried to run the SNDK demo in a notebook with Debian and got an error message. As far as I have understood, the problem is related to the SNDK Server.
The notebook's model is HP 14-an0202 and it has the following features:
- Microprocessor: APU AMD Quad-Core A6-7310 (2 GHz to 2,4 GHz, 2 MB cache)
- RAM: SDRAM DDR3L-1600 of 8 GB (1 x 8 GB)
- Hard drive: SATA with 1 TB and 5400 rpm.

This notebook has got installed the next distro and kernel:
$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.6 (stretch)
Release: 9.6
Codename: stretch
$ uname -srm
Linux 4.9.0-8-amd64 x86_64

And when I ran the demo I got the following message:
$python main.py,
Traceback (most recent call last):
File "main.py", line 100, in <module>
main()
File "main.py", line 13, in main
if conn.startServer("..") is None:
File "/home/new-mauro/Descargas/Linux/Linux/SNDK-20141113/PythonClient(modificado)/connection.py", line 42, in startServer
self.server = subprocess.Popen(arglist, stderr=server_stderr)
File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory

Then, I tried to initialize the server by my own and I got the next error message:
$./SpectranUsbTcpBridge
bash: ./SpectranUsbTcpBridge: No existe el fichero o el directorio

Do you know what's the reason of the problem? Did you develop the SNDK server to be used in a specific linux version or a specific distro?
I hope you can help me. Thanks!


Quote
Share: